2

I'm using Praat for the first time. When I try to annotate a Chinese speech segment, for some reason the Chinese characters I entered all get displayed as blocks in the corresponding tier:

Picture

I'm on Ubuntu 16.04 LTS and the Praat version is 6.0.04. Strangely I couldn't find any result on Google and it seems that I'm the only one who's encountering this issue?

2
  • That means you don't have the font for them, I think. – Akiva Weinberger Nov 1 '16 at 20:49
  • @AkivaWeinberger Well, just checked and I definitely have Noto installed, both Sans and Serif. Never had this issue in any other program. You can see that the Chinese font is displayed correctly above, where I actually type. It's only a block down below, in the tier area. Maybe Praat is using another font in the "tier" area? But I don't seem to find any option to adjust the font used in Praat. – xji Nov 2 '16 at 0:02
1

I can reproduce this on Debian jessie, which shows the characters as nothingness (as in your case, compare the white entry box in the top with the yellow in the bottom):

enter image description here

As you can see, my system too is fully Unicode and has the relevant fonts. I think this is a bug; Praat probably uses a UI toolkit to let the system draw fonts, and for whatever reason it's not using the font fallback stack properly on Linux. There are font options for Pictures on .praat-dir/prefs5, but nothing for annotations except font size. The manual entry for annotation objects specifically claims that you can use Chinese characters. We should report this bug to Praat devs.

1
0

Try installing a more complete font, like Google Noto or Adobe Source. That "tofu" appears when the program can't find an appropriate font which contains the appropriate character; Noto in particular is designed to contain as many characters as possible, to avoid that problem.

2
  • Well, just checked and I definitely have Noto installed, both Sans and Serif. Never had this issue in any other program. You can see that the Chinese font is displayed correctly above, where I actually type. It's only a block down below, in the tier area. Maybe Praat is using another font in the "tier" area? But I don't seem to find any option to adjust the font used in Praat. – xji Nov 2 '16 at 0:02
  • Ugh, that's unfortunate. (My guess was that Praat was designed to pick its font only once at startup, but the textbox above used a standard GUI toolkit which would try to choose the right font for each character. But that doesn't help if there's no way to change the font...) Preferences should be saved in ~/.praat-dir/prefs5 and there might be font options in there. But I don't have Praat on this machine so I can't experiment myself. – Draconis Nov 2 '16 at 0:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.